OwnCloud - Internal Server Error


Wenn Sie Owncloud mit dem OwnCloud-Webinstaller installieren, kann es zu Problemen mit der Installation und PHP 7 kommen.

Der Web-Installer lädt nämlich die veraltete Version 9.0.1 herunter, welche noch nicht mit PHP 7 kompatibel ist. Um das Problem zu beheben, können Sie die aktuelle OwnCloud Version 9.0.2 (oder in der Zukunft folgende Versionen) herunterladen. Sollten Sie OwnCloud in der Version 8.x in Kombination mit PHP 7 verwenden wollen, müssen Sie auf die Version 8.2.4 (oder neuer) zurückgreifen.


 Sollten Sie OwnCloud mit MySQL installieren wollen, benötigen Sie die storage-engine InnoDB. Eine Installation von OwnCloud mit der storage-engine MyISAM ist technisch nicht möglich. Sie können bei World4You eine InnoDB-Datenbank kostenpflichtig erwerben und zu Ihrem Domainserver Paket hinzufügen. Alternativ können Sie die Installation mit einer SQLite Datenbank durchführen.


Weiters kommt es zu Fehlern, wenn Sie PageSpeed (mod_pagespeed) auf Ihrem Domainserver aktiviert haben sollten. Um Fehler mit PageSpeed und OwnCloud zu verhindern, müssen Sie dieses Modul deaktivieren.


Hier finden Sie die ausführliche Anleitung zur Installation von OwnCloud bei World4You.